You will need Adobe Reader to view the catalog.  Click on provided link to get the most current Version.